FDB Cloud Services Update

Incident Report for First Databank

Resolved

The update from CrowdStrike that caused the global IT outage has been rectified. We have confirmed with our cloud providers that the issue is addressed and that any new resources needed to meet demand will not be impacted. During this time we did not see any latency or error issues.
Posted Jul 19, 2024 - 14:55 EDT

Update

We are continuing to monitor for any further issues.
Posted Jul 19, 2024 - 14:52 EDT

Monitoring

We are aware of the global IT outage occurring caused by CrowdStrike and we are watching closely, but at this time, we do not see any impacts to Cloud Connector, Navigo, TMW or Alertspace. We have taken precautionary steps.
Posted Jul 19, 2024 - 07:53 EDT
This incident affected: FDB AlertSpace, FDB Cloud Connector, FDB Navigo, and FDB Targeted Medication Warnings.