FDB AlertSpace experiencing outage

Incident Report for First Databank

Resolved

This incident has been resolved.
Posted Jul 12, 2025 - 20:53 EDT

Investigating

We are currently experiencing an outage impacting AlertSpace. Our team is actively investigating and working to restore service as quickly as possible. We understand this is disruptive and apologize for any inconvenience. Updates will be provided as new information becomes available.
Posted Jul 11, 2025 - 15:01 EDT
This incident affected: FDB AlertSpace.